Warning

This document is outdated. FIXME: Contains HiFi hosted content, only talks about FBX, Blender changed a LOT

Tutorial: Modificar Materiales y Texturas usando Blender

Blender es una herramienta de modelado 3D de código abierto que puedes utilizar para ajustar tu avatar y asegurarte de que los materiales y texturas se renderizen correctamente en Vircadia.

En este tutorial, te guiaremos a través de modificaciones simples que puedes realizar a tu avatar usando Blender. Necesitarás importar un archivo FBX para tu avatar. Si no tienes uno, mira nuestro tutorial para Mixamo.

  1. En Blender, ve a File > Import > FBX (.fbx).

  2. Elije el archivo FBX de tu avatar y haz clic en "Import FBX". Esto abrirá tu avatar en la vista principal.

  3. Por defecto, no verás los materiales en tu avatar. Puedes cambiar tu vista usando la barra de herramientas en la parte inferior de la vista.

  4. Para ver mejor tu avatar, cambia la configuración de lamp:

    • Desde el Esquema, haz click en el nodo Lamp en Blender.

    • Para "Type of Active Data to display and edit", elije el icono "Data".

    • Cambia lamp (lámpara) a Sun (Sol).

    • Gira la lámpara para iluminar tu avatar.

  5. Desde el Esquema, abra el árbol "Armature" y selecciona el elemento que deseas ajustar. También puedes hacer click en el elemento directamente en tu modelo.

  6. Con la caja de herramientas a continuación, puedes cambiar los materiales y la textura de cada parte del cuerpo como desees. Hemos incluido un ejemplo a continuación que Cambia las pestañas de nuestro avatar. Puedes seguir pasos similares para otros elementos de avatar.

    Note

    To remove a metallic feel to your avatar in Vircadia, we recommend changing the default Specular Intensity for each of the main body parts from 0.500 to 0.000.

  7. Cuando hayas terminado de cambiar tus materiales y texturas, ve a File > Export > FBX (.fbx).

  8. Cambia el "Path Mode" a "Copy", luego haz click en el icono de "Embed Textures". Esto asegura que todas las texturas estén incrustadas en tu modelo.

  9. Dale a tu avatar un nombre único.

  10. Click en el botón "Export FBX".

Ahora, estás listo para traer tu avatar a Vircadia.

Ejemplo: Actualizar Pestañas a partir de una imagen

  1. Guarda esta textura en un directorio que recordarás.

  2. Desde el Esquema, abra el árbol "Armature" y selecciona "Eyelashes".

  3. En la caja de herramientas a continuación, haz click en el icono "Materials".

  4. Haz clic en el botón "+" junto a la lista de materiales para crear una nueva ranura de material.

  5. Haz click en "+ New" para agregar un nuevo material.

  6. Cambia el nombre del nuevo material a "lashes".

  7. En la parte inferior de la ventana de Blender, cambia a "Edit Mode".

  8. Debajo de la lista de materiales, haz clic en "Assign".

  9. Desplázate hasta la sección "Transparency". Marca la casilla de "Transparency" y cambia el valor "Alpha" a 0.00.

  10. Desplázate a la sección "Specular". Establece el color especular en negro.

  11. Cambia a la vista "Textures".

  12. Haga clic en "+ New' para agregar una nueva textura.

  13. Desplázate hasta la sección "Image". Haz click en "Open" y busca la textura de las pestañas llamada "mixamo_eyelashes" que descargaste anteriormente. Haz clic en "Open Image".

  14. Revisa las opciones "Alpha" en las siguientes secciones: Image, Preview, Texture, Influence

  15. Ve a File > External Data > Pack All Into .blend. Esto incluirá la textura en tu modelo.

Ver también